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Graphing data

Vegetation biomass test data
1. With EML
2. Without EML




ER Biomass Plots

B3 Microsoft Excel - 1999_npp.csv
HE T Help  Adobe POF

NEHRERIVE SR S8 bR B - oo
PP R 7 @ A |55 | ) By (g3 | ¢ Reply with Changes... End Revisw, . !

Edit ¥iew Insert Format Tools Data  ‘Window Type aquestion forhelp = o & X

#e [ ¢ [ o | EW F 6 [ H [ 1+ [ 40 [ vk [ L Jx
DATE SITE WEB PLOT QD SPECIES OBS COVER | HEIGHT COUNT  PHEMN COMMEMNT —
2/3A1999 FPC 1E 1 ERPUS 1 0.5 4 13 A,
231999 FPC 11 E 1 ERPLS 2 01 2 16 % MA
2/3A1993 FPC 1E 1/GUSA2 1 0.m 4 2% MA,
2/3A1999 FPC 1E 1/GUSAZ 2 0.1 5 1% A,
2f3A1999 FPC 1E 1/GUSA2 3 0.5 12 1% A,
2f3A1999 FPC 1E 1/LEFE 1 0.25 5 1% MA,
2/31993 FPC 1E 2 LATRZ 1 7 36 2 MA,
2/3A1993 FPC 1E 2 LATRZ 2 2 32 3 MA,
2f3A1999 FPC 1E 2 LATRZ 3 8 B1 1% A,
2/3A1999 FPC 1E 2 LATRZ 4 3 45 1% A,
231999 FPC 11 E 2ILATR2Z 5 2 24 1% MA
2/3A1993 FPC 1E 2 ERPUS 1 0.25 3 3 MA,
2/3A1999 FPC 1E 2 ERPUB 2 0.05 2 1M A,
2f3A1999 FPC 1E 2 LEFE 1 0.1 4 I A, 3

W4 v W 1999 npp /

Ready UM

Fil= Edit

Format  Wiew Help

Figure 2. Quadrat Layout

DATE, SITE, WEB, PLOT, QD, SPECIES, OBS, COVER, HEIGHT, COUNT, PHEN, COMMENTS A
2,’3,’1999 FF'C 1 E,1,ERFUS,1,0. 5 4, 13 W, MA

2/3/1999, FPC,1,E,1,ERFPUS, 2, 0. 1,2,16 W, WA
2431000 FPC.1.E,1,GUSAZ, 1. 0. 00,4, 2 W) NA
27371900, FpC,1,E,1,GUSA2,2,0.1, 5,1, v, NA
2/3/1999,FPC,1,E,1,GUSA2,3,0.5,12,1, W, ha
2/3/1%%9,FPC,1,E,1,LEFE, 1 D 25,5,1,V, MNA
2,/3/199%, FPC,1,E, 2, LATR2 1 T.36,2,W, NA
2,-’3;"1999,FF'C,:I_,E,2,LATR2,2 2,32,3,W, N
2/3/1999, FPC,1,E, 2, LATRZ, 3,58, 61,1, V, MA
2/3/1999, FPC,1,E, 2, LATRZ,4,3,45,1,V, NA
?/3/199%, FpC,1,E, 2, LATRZ, 5,2, 24,1, Vv, NA
?/3/1990, FpC,1,E, 2, ERPUB, 1, 0.25,3, 3,, NA

£

West Plot

BE o~ 2 AN A sessasasae oM 0 O
South Plot D<-~~> @ ~~>D - North Plot




This Exercise

O Using a subset of the data for 1 species In
1 guadrat, extract vegetation cover% and
height, and create bar graphs of those
values through time

E veg data_test.csv - Notepad
File Edit Faormat  Yiew Help

DATE, SITE, WEE, PLOT, QDy, SPECIES, OBS, COVER, HELGHT , COUNT, PHEM, COMMENT S
2/3/10900,FpC,1,E,1,ERPUS,1,0.5,4,13,V, NA

2721009, FpC,1,E,1,ERPUS, 2,0.1, 2,16, V, NA

6/2/1999, FpC,1,E,1,ERPUE, 1, 0. 5,6, 2, Na, N

6/2/1909, FpC,1,E,1,ERPUS, 2, 0. 25,4,12, NA, MA
6/2/1999,FPC,1,E,1,ERPUS, 3, 0.1, 3,10, NA, MA

6521999, FpC,1,E,1,ERPUS, 4,0, 05, 2,13, MNa, M

1lo0/7/1%999, FpC,1,E,1,ERPUS,1,0.25,7, 5, F, NA

10/7,/1999, FPC,1,E,1, ERPUS, 2, 0.1,7,2,F, NA
10/7,/1900, FPC,1,E,1, ERPUS, 3, 0. 01, 2, 31, F, HA




With metadata (easier)

Quick Search | Source

Yyywvwyy
|
| £

O Open a new graph
editor in Kepler

File->New->Graph
Editor

o Switch to the Data
tab

O Search for “test”

0 Add Vegetation Test
Data to canvas

Drag and drop

o Display ports

Move the icon slightly
to refresh

LTER




S&K

Edit parameters for, Vegetation Test Data

@ EML File:

achemalet:

sglDef:

output Ty pe:

Target File Extension in Compressed File:
recordid:

endpoaint:

veq_data_test-caw:

Explore the dataset

td

|[ Browze ]

schenas

«<field name="0D"

<table name="vey data test.cav':
<field name="DATE" dataType="STRING"/>
<field nane="5ITE" dataType=""3TRING"/ >
<field name="WEE" dataType="3TRING"/>
<field name="PLOT" dataType=""3TRING"/ >

dataType="STRING" /=

<field name="3PECIES" dataType=""3TRING"/>
<field name="0B3" dataType="STRING" />
<field name="COVER" dataType="3TRING" />

| >

Graph Debug Help

0o Show the schema

Double-click on icon or
right-click-
>configure

O Tool tips on ports

QaTa D PNOPRROD e

| actare | bta |

Az Fieldd

Guick Search

test

dpennington. 32.2

! Testuco graeca

ylogzalzerviceslorglecoinfar

EF' masticophis flagelum testaceus
! rvicanthis rilclicus testicularis

[ Lophiotnys imhausi testudo

Cormmit ] [ Add ] [ Remove

] [Restore DeFauIts] E

[t TEST 2
[ Test for Elbwood maoting

Vegegation Test Data

t

B

Vegefgtion Test Data

PHEM, type:string

.
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File Miew Edit Graph Debug Help

Director

G @e I PINIOCP R e

Quick Search

| directors

[Fltext  [+] concs pt

;‘l Search Results
=4 Workflow Componerts
(= 4 Directors
== ¢ Director
== c1 Director
== e pirector
==

|~

SDF Director

“VEYYYY

tion Test Data

|

o Add a director
Click on the Actors tab

Double-click on Workflow
Components

Double-click on Directors
Drag and drop the SDF Director
onto the canvas
0o Configure director

Double-click or right-click-
>configure

Change iterations to 9 (the
number of rows to be read in
the file)

Click Commit to save

Edit parameters for SDF Director

Exception

@ allowwDisconnectedGraphs:

allowRateChanges:
terations:

vectorizationFactor:

=<0 O

ommit &dd

I J

Remove

] [Resture DeFauIts] [ Preferences ] [

J

Help Cancel ]

4 KNB




Display the file

O Search for
“display”
oy (=n

o | - o Find the Display

~
Mext Disgram

IEI Palygon Disgrsn

ew Edt Graph Debug Help

awa@aT P HNOPR ROL e

Actors ‘B;t;\

CEX

B

Quick Search SDF Director

-
@I Palygon Disgrsn : C O r
o benmal Vegelgtion Test Data Liisplay a t
Broweserll i r
Browvser Dis "ﬂ' = El
= 4 Scopes

B sequence S

0 Drag and drop

Array Plotter
Sequence Pl

the Display actor

= _A Ortalogy Browse

[=] onto Brows:
B _4 Graphers
onto the canvas
=4 Textual L
(= Jowsisy v
< | >
5 resuts found
"SOF Dirooir

(s

I

Exception. |




Hooking up ports

B

E_Etl“ D.eug:e“ O coe

ccccccccccc o Find the “cover” port

o T — Use tool tips or view schema

e Note string types

o Click-hold the cover port
and drag to the input
port on the Display actor

0 Run the workflow

Click the red triangle or
View->Run Window->Go

O Delete the Display actor

=
g
8
@
2| &
@
=
3

=3

LTER




String conversion

lomares 5] O Search for Expression to
N TS T T " Token actor
‘ 1 O Add Expression to Token
e o actor to canvas
e O Configure ports
e : Right-click->configure ports
r“‘ Change input port Type to
< _ string
S Change output port Type to
double
Commit
CERS 0 Hook up Cover data output
o oyt port with Expression to
i Token input port
[
Outpt | Multiport  Type Direction Zhowy Mame Hide Units
E N Direciion ks =

DEFALLT 1 ]

LTER

Apply Ao Remove [ Help H Cancel ]




String conversion

Fle Wiew Edit @raph Debug Help

| ®4 1 Repeat for Height data
e CMNSEEC SO output port

S g o Copy and paste

o o — Expression to Token

_ actor (Edit-> Copy->

paste or cntl-c cntl-v),
Move copy from over

original
. 0 Hook up height data
- sagmn output port with

= 4 Graphers

— Expression to Token

E Display A

e Input port

|

| HEIGHT, type:string [ Expression To Token2

@
2
&
2
g H
= 3
= i
E
E
z
H
i g
7 B
i
|A
|aeil £

LTER




Add graph

Expression To Token

ed O
File Wiew Edit Graph Debug Help
@ a I PO RE>He
Actors ‘E)at; ]
Quick Search SDF Director
! graph | [ Go }
text concept
ch Resutts e
Workflow Cormponents
T Actors :
B4 Outputs p-
= _4 @raphical Displays Vegel ;n’on TestData
Mext Diagram r
-

@ Palygon Diagrams D
EI Palygon Diagrams Ti
= i External
= Browserll
EI Broveser Displs:
=2 4 Scopes
Sequence Scop
X Scope
Timed Scope
= 4 Plotters
Array Plotter
Sequence Plotte
lotter
Timed Plotter  —
Histograrm Plotte:
= 4 Ontology Brovesers
(] Pt FBersnear | 2

< |

17 resulis found.

SOF Comei

M-Etmhnmu
F) a1 faan

e T

S

YYYYy

XY Plotter
o]

execution finished.

.

O Search for “xy
plotter”

0 Add XY Plotter
actor to canvas

0 Hook up Expression
to Token output
ports with XY
Plotter input ports




Run the workflow

o Click the Run button (red
triangle)

O Note lousy plot
format..close the display

o Change the plot format
View->Run Window

Click on small plot format
icon

¥4 Unnamed |Z| |E| rz'
File Wiew Debug Help ~ |
: | <<——
[ Gao J [ Fauze ] [ Resume ] [ Stop ] XY Plotter EJ&@
= = = = L T T T T T T T T T T T ]
Directar parameters: o
BA [
allowhisconnectedGraphs: (7 G0
allowRateChanges: O 5510
iterations: q S0
ctorizationFact 1 a5t
40
B
B
25
20| LTER

Il L 1 L Il L 1 1 Il L Il
000 0os 010 045 020 025 030 035 040 045 0450

—




Set plot format

2

Title:
X Lakel:
% Label:

X Range:
Y Range:

harks:

W Ticks:
Y Ticks:

Reformat the plot

Yegetation volume

Cover percernt

Height

001,05

20,70

O none O points @ dots O warious O pixels

Gricl:
Stems:

Connect:

Use Calar:

®@00®

Change Title to
something meaningful (I
used Vegetation Volume)

Add axis labels
Select dots

Unselect Connect
Apply

Close Run Window
Run from red triangle

Save your work

File->Save->
c:\kepler\workflows\eco\
veg data xxx.xml,
where xxx is your initials

LTER

KNB '




SPEK

Without EML

o The harder way, without EML-
described metadata




Cheat-look ahead

Copy veg_data_test.csv from shared directory to
c:\kepler\workflows\eco\

Copy veg_data.xml from share directory to c:\kepler\workflows\eco\

Open veg_data.xml from Kepler->File->Open File-> [locate file]

P:ﬂ file: /C: M orkS pacefkeplerfworkflows/ecofveg data.xml |Z| |E| El
File Wiew Edit Graph Debug Help

@ aTPNOPRE > oS

e Tou] Opens the file
L Separates file into rows/columns
Extract cover and height columns
Converts to decimal number
v l rConstructs bar graphs

Delimited Parser

Expression To Token

Expression

“("rinput{7 )"

«n NOtE: all this would not be
‘ necessary if EML used

Expression2 ssion To Token: Bar Graph2

0 results found
E=m
-“',_:P.;... — peirer
S LTER

|~




Play with the workflow

Run workflow (click the red triangle)
Move the top graph so both can be viewed
Animate the execution Debug->Animate execution — set for 1000 ms

Run workflow...move graph windows so you can see the animation
Close the bar graphs

Run from run window - View->Run Window-> Go

5] .veg_data.Bar Graph

OooOoooao

O

CEX

4 file: /C: /WorkSpace/kepleriworkflows/ecolveg_data.xml Fle Edt 3pecial Help
Fie View Edit Graph Debug Help @E@E
£y
@a@aTINOP R MDD e N 7 S
Actors | Data) 0.4
Quick Search
0.4 8
L]
text concept SDF Director = I |
{1 Workflow Componerts =
o
0.2 8
ol . . . _
File Reader
0o | —_
H Delimited Parser Bar Graph 1 1 1 1 1 1 1 ! !
g= Expression Expression To Token
3 1} 1 2 3 4 ] G 7 8
! :
P il O Time step
Expression2 Bar Graph2 i ep_data.Ba = 5
“(+input(8)+ ) File Edit Special Help
. =]
Height JJJJ
T T T T
7
]
]

=

i~

o = rnow

1

T T T T T
O resutts found. L 4
[EES=S
gar ]
T e L |
E.’::._.j‘{"_"‘"' & I
1} 1 2 3 4 5} B 7 8

Time step




Start a new workflow

O Open the workflow editor
File->=New->Graph Editor
O Select a director

Double click Workflow Components
Double click Directors

- Drag and drop SDF Director
CaEeDrNOPREOL O |z Configure director
e | Right click on director
e | Change number of iterations from O to 1
Commit

Edit parameters for SDF Director

@ allowwDisconnectedGraphs:

O
allowRateChanges: .{_“_3.
terations: 1
e vectarizationFactar: 1
SDF Director
ommit l [ &dd ] [ Remove ] [Resture DeFauIts] [ Preferences ] [ Help
<

X
| —




Read the file

O Add the File Reader actor to the canvas
Select Actors->Inputs->External-=Readers
Drag and drop the File Reader actor

O Configure the actor

[ T — Double-click or right-click-=configure
3;;;.. RN TITE TG Browse for the veg data test.csv file
Commit
]

text concept
[ orb wavetorm £ A

[=] Orb Packet Obje
[88] File Stager
[8a] File Fatcher
Do
] Database
1 Storage Resaurc
] Globus

= ey
Edit parameters for File Reader X
@ fileQrURL: |C:Wkepler'l.wu:urkflDws'l.ecu:ulveg_data_test.l:sv [ Browse |
[ Camrit ] [ Add ] [ Remove ] [Rest-:.re DeFaults] [ Preferences ] [ Help ] [ Cancel ]

v

.




Display to check

0 Add a Display actor, to check that the
actor is working

P8 Unnamed . ’y
Y T IY T I T TUY SCELEO LT BT s :
e Drag and drop the Display actor
—— O Hook up ports between the 2 actors
g B Click-hold the output (right) port on the File
o Reader actor and drag to the input (left)
e port on the display actor, then release
2 S — 0 Run the workflow

1= _4 Graphical Displays
@ Polygon Diagrarr
@ Polygon Diagrarr

NextDiagram
1 Esternal
__| Scopes
__1 Plctters K =
1 Ortalogy Brovese ‘.q ..I}lsplﬂ.‘,I
| Graphers
= —"ﬁ“;' A— File Reader Dlatay Filz  Help
B
-D;‘ s .-- 2/3/1999,FPC,1,E,1,ERPUS,1,0.5,4,13,V, HA A
. :" )Z 24341999 FPC,1,E,Ll,ERPIIS,2,0.1,2,16,V HA
0 resuits found. 6/2/1999 FPC,1,E,l,ERPIIE,1,0.5,6,2 A, HA

e 6/2/1999,FPC,1,E,1,ERPUS,2,0.25,4,12,HA,
6/2/1939,FFC,1,E,1,ERPUS,3,0.1,3,10, A, N
6/2/1999,FPC,1,E,1,ERPUS,4,0.05,2,13,N4,
10/7/1999,FPC,1,E,1,ERPUS,1,0.25,7,5,F, )
; 1047/1999,FPC,1,E,1,ERPUS,2,0.1,7,2,F,HA
o frished. 10/7/1999,FPC,1,E,1,ERPUS,3,0.01,2,31,F,

sploy

m.
i (e
g I
5
:
=
:
* 0
|l

£ |



Parse the file

Ay le:JC:MWorkSpace/kepleriworkflows/ecofveg data ddp.xml

File Wiew Edit Graph Debug Help

G @e- PO EE e

Actors |E|

Quick Search

|

text concept

‘J ‘Workflowy Components o
| Directors
= 4 Actors
= 4 Mathematical Operations
O

I terative Operators
1 Random Mumbers
1 Avithmetic
I Discrete
) Unit Systems
| Statistics
1 Trig
) Caloulus
] Cortral
1 Image Manipulstion
1 Grid Functions
] wieh Services
| Datamining
| Domain Specific
;I External Execution Envira
1 Inputs
| Fiters
FL ) Panstants

4 >

v

0 resutts found
0% Dirsciar

|l\

SDF Director

File Reader

Delimited Parser

Display

Move (but keep) Display actor
Delete port connection (click->delete)
Move actor to right
Quick Search for Delimited Parser actor
Type “parser” in text entry box
Click Go
Drag and drop Delimited Parser onto canvas adjacent
to File Reader
Configure Delimited Parser
Double-click or right-click->Configure
outputFormat = column
Delimiter = “,”
numberColumns = 12 (refer to Display actor output)
numberHeaderLines = 1 (refer to Display actor output)
CCommit

Edit parameters for Delimited Parser

2

execution finished.

outputF ormat:
delimiter:
numberCalumns:
numberHeaderLines:

firingsPerfterstion:

calurmn b

Cornrnik

|| add

] [ Remove ] [Restu:ure DeFauIts] [ Preferences ] [ Help ] [ Cancel i




Parse the file (cont’d)

-
h',-’:lUnnamed
Fle Wiew Edit Graph Debug Help

EEX

ca@ead P ISP REED> e

Actors ‘6;1;|

_4 Sesrch Resutts
4 workflow Components
B4 Actors
= _I String Functions
Jelimited Parser

SDF Director

File Reader Delimited Parser

Display

B
i- -‘:

[
g
:
i
[0
|

[

% Configure ports for Delimited Parser

Output - Multiport - Type

Configure Delimited Parser

output port
Right-click->configure ports
Find stringOutput output port

Change Type to {string} (braces are
important..make sure to include
them)

Commit

Hook up File Reader/Delimited
Parser ports
Connect File Reader output port to

uppermost, black, Delimited
Parser input port

Direction Showy Marne Hicle: Uit

DEFALLT

DEFALLT

DEFALLT

DEFALLT

DEFALLT

DEFALLT

OOOOOc
O

Rermove

[ Help H Cancel ]




Parse the file (cont’d)

BEl 0 Hook up the Delimited
e T PNOP R NDOD O Parser/Display ports
ctors | et A Use lower, type=string output
QukskSmsron port for Delimited Parser
[parser | (oo ) O Run
te>d c:onc:ept
= O Save your work!
= Eﬂhﬁr:f;;:;omponerﬂs File_>Save_>
= O S i browse to
% c:\kepler\workflows\eco\
name as veg_data2_xxx.xml,
where xxx is your initials
File Reader Delimited Parser Display
2 g3 . g -, File Help
(T2/3/1999,2/3/1999,6/2/1999,6/2/1999,6/
DDDDD o

execution finished.




Extract columns

FA file: /C: Wo rkSpace/keplerfworkflowsfeco/vep data ddp.xml |z| ‘E"z‘

File Wiew Edit Graph Debug Help

O Delete the connection to the Display

@D P NOPRE e
= a actor '
0 Move (but keep) Display actor
O Locate Expression actor
PR Search “expression” or Actors-
g — >Mathematical Operations
i Qs O Add Expression actor to canvas two

1 Random Mumbers - .
] Avithenetic t m eS
| Discrete I
1 Unit Systems

s Cis O Add input port to both Expression

) Trig

Yo actors
s Do S Right-click->Configure ports->Add
| Dataining File Reader L g
e Delinied Parer Check Input box for new port
2 S L Encis Click blank box under Name
,,.,_, 2 Type port name “input”
== Commit
,,,,,,,,,, = E——
e = BX]
- Outpt | Multiport  Type Direction Showy Marne Hicle: Units

DEFALULT F ]

nknowen  DEFAULT Fi Fi

[ Cornit H Apply ][ Ao ] Remove [ Help H Cancel ]




Extract columns-cont’d

A file:/C: M orkSpacefkeplerfworkflows/ecofveg data_ddp.xml ‘:||§|rg|
File ‘iew Edit Graph Dsbug Help

QxR T PNOP N NS e

Actars |@|

>

Gick Search

| |Cer] 0 Configure Expression

text cohcept

J Wiarkflowe Components ~ aCto rS

| Directors

gL A— Double-click or right-
& terae Oparrs click->configure

e ] L
= Sl Type In first actor:
é?;ﬁs{lics ll{ll+input(7)+11}11

& E1cua Type in second actor:

1 Image Manipulation

] Grid Functions ) T 114 = 8 77 77
o . EXPFESSIOH + +

] 'wieb Services L3 Display { I l l put( ) }

| Datamining "["+input(7)+"}"
| Domsin Specific File Reader Delimited Parser C . t

| Exterrial Execution Ervira B - . o

Clinputs L - BExpression2
o s}
| b3

0 results found.
Fy—

Erprisascn

Edit parameters for Expression

@ expression; | T HARLCT 1

[ ot l [ Add ] [ Remove ] [Restu:ure DeFauIts] [ Preferences ] [

|~




File Wew Edit Graph Debug Help

Extract columns-cont’d

F’] file:/C: MWorkSpacelfkeplerfworkflowsfecofveg data_ddp.xml

@D P NOP R B H e

F& veg data_ddp.Display
File  Help

CEX

Actors | Diata \

Guick Search

| (e ]

text concept

~ | winrkflowy Componerts

0 results found.

SDF Director
File Reader Delimited Parse
| >
» [

[0.5,0.1,0.5,0.25,0.1,0.05,0.25,0.1,0.0L

| [

>

I8 veg data_ddp.Display2
File Help

&=

{4,2,6,4,3,2,7,7,2}

Expression Display

AU+

Expression2

“{+input(8 )+

vl=

[ —

O Add relation

Cliclé (one time) on diamond on task
ar

Hook Delimited Parser lower
(stringOutput) output port to
relation

Hook relation to Expression input
ports

Hint: it’s easier to click on the
Expression port and drag to the
relation than vice versa

Copy the Display actor

Click on it

Copy and paste (Edit menu or
shortcuts)

Move copy so both show
Hook output ports on each
Expression actor to the input port
of a Display actor

Run

Move the top Display window so
you can see both

['TLR
)

/)

—



Convert to decimal number

¥4 .veg_data_ddp.Display =BIX,

l:F] file:/C: MorkSpace/keplerfworkflows/ecofveg data ddp.xml
File View Edit Graph Debug Help File  Help

Q@ T HOD R kD o qos o 05 0, 00,005, 02, ff| O Add Expression To Token actor
.Actors |E| i tWO tlmes

Search for “converter”
P8 veg_data_dap.Displayz (2 |E]X] o Configure port_s

o 3 e Help Input Type=string

[ 250202 Output Type={double}

4 Image Manipulation

Quick Search

| cormerter

teut concept

=

T - Commit
B — O Hook up Expression output ports

Image Converter

[x] To A\ﬂlg - p O rtS

El File To String Converter
Chject To Record Converter

I Toon coe O Hook up Expression To Token

Convert Image To String

6] T A o output ports to Display input

:":g; Tr°0 ':i:::z:'ogmvem Expression Expression To Tokdbisplay
Sing To XML e Reader THnpUT) ) 8]0 rts

Delimited Parsg
String To Image Converter
Il Palar T Fawmmlay v .

< (@
14 resutts found.

Expression2 Expression To T"k‘%‘rgpla‘ﬂ D R u n
>

(" +Hnput@)+ )

o (=1[E9

It Outpt | Multiport  Type Direction Showy Marne
i DEFALLT Fi
DEFALLT Fi

Cornit H Apply ][ Ao ] Remove [ Help H Cancel ]




o

N

eV 5 Construct bar graphs

L=]] 1l

Bar Graph

o

=

Guick Search

w

|display H Ga ]
[¥ltext  [¥] concept

[ & A Graphical Display |
@l Polygon Disn
@ Palygon Dian
Mt Disgran
= 4 External

(8]

o =

T T T
0.50
0.45 T 1
0407 1
0.35[ 7 5] .veg_data ddp.Bar Graph2 |:||E|rz‘
0.30 b Fle Edt Special Help
0.257] 1 I 2
F H J Bar GraphZ
g orkSpac: B T T T T T T T T T
File View Edt Graphl| 0.15 1 T 1
Q+ Q':‘@@v o I I I | | 7
—— 0.05 T 1
sators | peta | 0.00 | | | I 7
i 1 2 3 4 5 6 7 8 I I
1] 1 2 3 4 5 3] T g

Erowse
Browse
= 4 Scopes
Sequen SDF Director
[El] Timeds
[ET] v sco

= Caper O Delete Display actors
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Configure Plots
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Conclusion

0 Take home message....

Use EML to describe datasets...
Some pain now vs. much pain later




