RCN Training

November 3-7, 2003

Lab 10: GPS Acquisition

Acknowledgement:  Many of these materials are from Sevilleta LTER’s technology reference website.  The GPS section was written by Greg Shore, now at the LTER Network Office.  His excellent online reference materials may still be accessed at http://sevilleta.unm.edu/technology/reference/

Overview 

The stages of a GPS mission can be divided into 3 parts:

1. Mission Planning

2. Data Acquisition

3. Data Offload and Export

This lab exercise will walk you through all 3 parts, after which you should be able to collect your own data from the field and import it into an ArcGIS project.  We will be GPSing the buildings, sidewalks, parking lots, trees, and shrubs around the Sevilleta Visitor Center.
Part 1: Mission Planning
Effective GIS analysis of GPS-collected data depends on the quality of the field work, which is greatly enhanced by mission planning, which can be divided into several components:  a) equipment checks, b) determining periods of suitable satellite visibility, and c) creating data dictionaries. 

A)  Equipment Checks

We will divide into 5 groups of 3, distributed between 5 GPS units:  1- Trimble ProXL, 1- Trimble ProXR, and 3- Trimble GeoExplorers.  The data logger components of these units are very similar.  The ProX- series has higher precision and accuracy, and are equipped for real time differential correction in the field.  We will not be using that feature.

An RCN instructor will meet with each of these groups to go over equipment features.  For your reference, Appendix A is a description of GeoExplorer configuration settings.
B)  Satellite Visibility

We will not be checking satellite visibility today; this section is provided for your information only.  This component of Mission Planning is to determine suitable observation periods for conducting GPS mapping/navigation that meet desired quality assurance criteria (e.g., PDOP, SNR, etc) under expected conditions (e.g., steep canyons, plant canopies, etc).  This involves collecting a current Almanac file (which contains satellite orbital and health information) with a GPS unit, offloading the almanac file to a PC using Trimble's PFINDER software, then using a software package (pointing to our almanac file) to determine GPS "windows".  There are several (usually vendor specific) software utilities available for determining these "windows" of opportunity.  Trimble's Windows-based satellite visibility utility called QUICKPLAN.  
C) Data Dictionaries

Data dictionaries allow you to establish in advance, well-thought out file structures and attributes, enabling efficient collection of feature and attribute information alongside GPS  positions.  All of your data can be collected into a single file, sorted out, and have detail added later based on field notes, but this method is error prone, and typically results in additional trips to the field to make corrections.  Once created, the dictionary is downloaded to your GPS unit, where it prompts you to enter information as you are collecting data.  

The data dictionary you create depends on your intended application (or possible future applications by someone else with the same data).  It is generally useful to subdivide data collection of different kinds of features into different files (e.g. points, lines, and polygons).  Further subdivisions depend on the data being collected. For example, if you are collecting locations of vegetation species, you might have two files, one for points of isolated occurrences, and another for polygons around patches. You might separate different species into different files, or you might include them in the same file, with a “species name” attribute.  You should enter other information that might be relevant as attributes, such as height or vegetation condition.  These may be codified for numerical input, menus of options, or free text.  More structured attributes (numerical or menu-driven) are preferable to free text.  However, menus should usually include an “Other” option, with a separate attribute available to record free-text “comments” that provide an explanation.
For this part of the lab, each of the persons in your group should create their own Data Dictionary.  When finished, you will compare dictionaries to note how the same data could be modeled in different ways.  Then, you will choose one of the dictionaries to download onto your unit for data collection.

1. From the Windows Start menu, open Pathfinder Office.  Choose “Utilities” =>  “Data Dictionary Editor”.
2. Create a name for your data dictionary.

3. Choose “File” => “Save As” and direct the file to your home space.

4. Create a dictionary for the buildings that you will GPS.  Choose “New Feature”, and type “Buildings” into the “Feature Name” box.  Click the “Area” option.  Tab to “Default Settings”.  We are going to use the defaults, but here you could specify feature-specific controls.  Note that you may set an “Offset”, which would allow you to GPS a feature when you cannot exactly reach it.  For instance, you might want to GPS the edge of a stream with steep banks by walking 5 meters to the side of the stream.  This setting causes the GPS unit to automatically make that correction.  Tab to “Line Style”.  Choose a color or thickness for the building lines.  Leave “Join” checked…that option causes the series of dots logged by the unit to automatically snap together into a line.  Click “OK”.  You should see “Buildings” listed in the “Features” box.  
5. Now we want to attach attributes to the “Buildings” feature.  Click on “Buildings” so that it is highlighted, then click on “New Attribute”.  You are given a choice of 7 attribute types.  Menu allows you to enter a list of attribute codes/values from which the user must select one.  Numeric, text, date, and time are self explanatory.  “File Name” is relevant only if you have additional software that allows you to run a laptop concurrently with GPSing.  “Separator” creates a blank attribute between entries for display purposes, and can be useful if there is a long list of attributes.  Select “Menu” and click “Add”.  In the “Attribute Name” box, type “Type”.  Click “New”, and a pop-up box should appear, where you will specify menu codes and values.  Enter the following list, clicking “Add” after each entry:  “Main” code “M”, “Field Station” code “F”, “House” code “H”, “Auxiliary” code “A”, “Garage” code “G”, “Shed” code “S”, “Greenhouse” code “G”, and “Other”.  When you are finished adding menu options, click the x in the right hand corner to close the box.  The list should appear in the “Menu Attribute Values” box.  At the bottom of the “New Menu Attribute” screen, you will see “Field Entry” sections.  This is where you specify when the entry of this attribute should/must/can’t occur.  Normal will allow entry during either GPS initial collection “On Creation” or if you return later to edit a feature “On Update”, but does not require that an entry be made.  For many purposes, it is desirable to require attribute entry on creation, to prevent the collection of data without any accompanying attributes.  Click “On Creation Required” for the Building Type attribute, then choose “OK”.  On the “Data Dictionary Editor” screen you should now see “Buildings” in the “Features” box, and “Type” in the “Attributes” box.
6. Continue adding features and attributes for the following items:  roads, sidewalks, parking lots, trees, shrubs, pond.  Model trees and shrubs as points, roads and sidewalks as lines, and parking lots and pond as areas.  Note that some of the screens change depending on the choice of point, line or area.  Choose “Help” to get a description of any screen choices that you do not understand.
7. When you are finished creating your data dictionary, save it.

8. Compare data dictionaries with the other members of your team, especially attribute structure.  Choose a data dictionary for use in this exercise.

9. Close the Data Dictionary Editor.  Close Pathfinder Office, unless your data dictionary was selected.
10. Get your GPS unit, and make sure it is connected to a battery.  Retrieve a download cable (black coiled I/O cable).  Connect the rectangular port to a matching port on your processor, and connect the round port to the back of the GPS unit.  
11. Turn the GPS on, and select “Data Transfer” or “File Transfer” from the menu options.

12. In Pathfinder Office, select “Utilities” => “Data Transfer”.   The box that appears will have 2 icons in the upper right hand corner, which will indicate when the connection has been made (if not connected within a few seconds, there is some kind of hook-up error, select “Devices” and make sure it is set to “Com1”).  

13. Tab to “Send”.

14. Click “Add” => “Data Dictionary” and navigate to the location of the data dictionary you created.  Click “Open”.  The data dictionary location should appear in the “Data Transfer” “Files to Send” box.

15. Click “Transfer All”.  A timer will show you when the transfer is complete.  

16. On the GPS unit, escape out of the “Data Transfer” mode.  Select “Data Capture” => “Dictionaries” => “Review”.  You should be able to examine your data dictionary on the GPS unit. 

Part 2: Data Acquisition
1. Collect GPS data from around the F&W Visitor Center, down the road, and around the field station.  You have several hours to do this…make sure everyone in your group gets experience on all three of the feature types (point, line, area).  It takes a little bit to get the hang of it, so its suggested that you start somewhere where there are instructors nearby, and play around a little with files that you can delete.  
2. If there is going to be a lengthy gap between collection times (like for lunch) please turn the GPS unit off to conserve battery power.  The large batteries, when new, will last for a full day without recharging.  These batteries are not new, so conserve!

3. It’s best to keep different feature types in different files (points, lines, areas).  You may or may not have multiple files for each feature type (e.g. trees and shrubs could be in the same file using an attribute to distinguish between them, or they could be in separate files).  If you are ultimately going to want these as separate coverages, it’s easiest to collect them in separate files from the start.
4. AVOID COMMON MISTAKES

including:

· Do not block the internal antenna with your body or head,

· Be sure to hold the GeoExplorer steady during data collection,

· Avoid collecting data around metal objects (e.g., vehicles) or buildings, since this introduces multi-path errors,

· Not closing the data file before moving onto the next point (much easier to do then you might think), thus collecting extraneous data into the file which requires later editing (if you’re lucky to catch it).

· And it is recommended that you output the coordinates in the most accurate, universal coordinate system/datum (e.g., WGS-84 or NAD-83 Lat/Long), then transform into less accurate datums and planar projections (such as Nad-27).

5. Follow these instructions for mapping points, lines, or areas:

MAPPING

For maximum accuracy, you should set the data logging interval to match (synchronize with) the base station:

     "Configuration --> Rover Options --> Featura Logging --> Points --> 5s"

SURVEY A SINGLE POINT

---------------------

1.  Open Point Type Rover file: "Data Capture --> Open Rov. File"

2.  Collect GPS position fixes into file while holding the unit stationary over point.

3.  Close file:


"Data Capture --> Close File --> Yes"

    NOTE: "No" is the default close selection, so be sure to cursor to "Yes" and hit ENTER key; otherwise you'll continue to collect data while you walk to next point (so you'll have to edit the file).

SURVEY A LINE

-------------

1.  Open Line (walk) Type Rover File: "Data Capture --> Open Rov. File"

2.  Begin immediately walking along the road, or line feature, and adjust pace to avoid "chopping" curves.  Try not to collect position fixes closer than about 1 meter apart, though.  And try not to stop (unless you "Pause" the unit) along the way, because you have to edit out extraneous points.

3.  Close file at the moment you reach the ending point: 

"Data Capture --> Close File --> Yes"

    NOTE: remember precaution above on closing files.

SURVEY A POLYGON

----------------

1.  Open Polygon (walk) Type Rover File:  "Data Capture --> Open Rov. File"

2.  Begin immediately walking along the boundary of the polygon and adjust pace to avoid "chopping" curves.  Try not to collect position fixes closer than about 1 meter apart, though.  And try not to stop (unless you "Pause" the unit) along the way, because   you have to edit out extraneous points.

3.  Close file when you reach the starting point.  It will automatically snap the polygon closed:


"Data Capture --> Close File --> Yes"

Part 3: Data Offload and Export
1. Create a project directory in your workspace (each person in the group should do this).  Select “File” => “Projects” => “New”.  Type a project name, then Browse to relocate the Project Folder into your home directory.  Leave the “Backup”, “Export” and “Base” folders the same.  Click “OK”.  

2. Data files remain on the GPS unit until they are explicitly deleted, therefore the data collected by the “team” can be downloaded on each persons computer so that everyone goes through the following steps individually.

3. Retrieve a download cable.  Connect the rectangular port to the matching port on your processor, and connect the round port to the back of the GPS unit.  

4. Turn the GPS on, and select “Data Transfer” or “File Transfer” from the menu options.

5. In Pathfinder Office, select “Utilities” => “Data Transfer”.   The box that appears will have 2 icons in the upper right hand corner, which will indicate when the connection has been made (if not connected within a few seconds, there is some kind of hook-up error).  

6. Make sure you are on the “Receive” tab.

7. Click “Add” => “Data File” and select your files for download.  The files should appear in the “Data Transfer” “Files to Send” box.  You may remove any from the list that are not yours…sometimes older data files from prior users were never deleted.

8. Click “Transfer All”.  A timer will show you when the transfer is complete.  The files will be stored in the path you specified as your project directory, in the “Backup” subdirectory.  

9. Copy the Base Station correction files from the location specified by an instructor to your “Base” subdirectory.  These are only available on the hour for the prior hour (e.g., if you stop collecting data at 10:15 you have to wait until after 11:00 to get the base station files).  The filenames have the format sMMDDHHA.ssf, where MM = 2-digit month, DD = 2-digit day, HH = 2-digit hour (GMT) and A = 1-digit alphabetic sequence character (a-z).
10. Check the downloaded GPS data files.   Select “Utilities” => “Other” => “Check SSF Files”.  “Browse” => <select your files> => “Open”.  Check the “Fix corrupt records” box, then “OK”.  Repeat for the base station files.  Click “Cancel” to close the “Check Data Files” screen.

11. Differentially correct data files. In Pathfinder Office, bring up the "Differential Correction" window:  “Utilities” => “Differential Correction".  In the "Rover Files" section, select the rover files to correct:  "Browse” => <select files> --> “Open".  In the "Base Files" section, select the base station files:  "Browse” => “Local Search” => <set path to base files> => “Search".  "OK"
12. Verify or reset the base station reference coordinates.  The current coordinates for the Sevilleta base station should be the following:

Datum:                NAD-83 (1992) HPGN

System:               Lat/Long

Station Latitude:      34d 21' 17.36670" N

Station Longitude:    106d 53' 06.90272" W

Station Height (HAE): 1459.221 m

Antenna Height:       0 m

13. "OK".  Differential correction will be performed.  Note: this process generates output files with ".cor" filename extensions.  Do not confuse these with the original uncorrected files (that have ".ssf" filename extensions).

14. Export the corrected files to ESRI file format.  Select files to export:  "Utilities” => “Export".  "Browse” => <select files> => “Open".  Set the desired output export type (still in "Export" window): "Choose an Export Setup” => “Sample ArcView Shapefile Setup" or  => “Sample ARC/INFO Generate Setup" or “Sample Configurable ASCII Setup".  For this exercise, choose shapefiles.  

15. Bring up the export setup window to configure output (in "Export" window): "Change Setup Options".  

16. Set the file processing mode (in "Export Setup" window):  "Format” => “Type of Data to Export” => “Features".  

17. Set the filtering specification (in "Export Setup" window):  "Position Filter --> Filter by GPS Position Info --> Min Sat --> 3D".  "Position Filter --> Filter by GPS Position Info --> Max PDOP --> 6".  

18. Also uncheck everything except "Differential" & "Realtime Differential".

19. Set the file format (in "Export Setup" window):  "System --> <check applicable computer system>"
20. Set the map projection and coordinate system (in "Export Setup" window):  "Coordinate System --> Use Export Coordinate System --> Change".  Set the export units (in "Export Setup" window):  "Units --> Units --> Use Export Units --> Change".  Note: set these to be consistent with the map projection/coordinate system.  

21. Set the attributes to be output (in "Export Setup" window):  "Attributes --> Generated Attributes --> All Feature Types".  Note: set according to feature type to be output. Recommend checking all survey and statistical measures so quality of GPS work is well documented and can be examined for possible errors.
22. After above parameters are set, click "OK" in the "Export Setup" window, then "OK" in the "Export" window to execute export procedure. The export files are written by default to the "export" subdirectory in the Project directory.
23. In ArcCatalog, navigate to the Project/Export subdirectory.  Your shapefiles should be available for browse.  
Appendix A:  GeoExplorer Configuration and Data Collection
INTRODUCTION

------------

These are the instructions for basic configuration of the Trimble GeoExplorer units.  Also included are simple checks for GPS satellite signal and RTCM signal reception.

NOTE:  basic GeoExplorer menu control buttons are:

1.  The bottom button is the power on/off key.

2.  The "Esc" backs out one menu level.

3.  The center (diamond labeled) button is the ENTER key, and either traverses down one menu level, or accepts an entered value.

4.  The arrowed buttons are the cursor keys, and also serve to scroll through an alphanumeric list (i.e., serves as the keyboard).

5.  The angled arrow key is a TAB key, to tab through fields in the waypoint editor.

GPS UNIT CONFIGURATION

----------------------

1.  Connect the camcorder battery and power cable (located either in the small yellow pack or inside the green DGPS backpack), then plug the other end of the power cable into the GeoExplorer unit.  Alternatively, you can use the portable "AA" power pack located in the yellow pack.

2.  If you are within range of the RTCM signal, you might want to use real-time DGPS to map your site.  This has the advantage of not requiring followup post-processing differential correction in the office, but at a cost of a slight loss in accuracy.  On the   GeoExplorer unit, this is the setting (check other settings as well): 
     "Configuration --> RTCM --> Mode --> Differential (i.e., GPD)"

3.  If using real-time DGPS, then plug the I/O cable from the green DGPS backpack into the back of the GeoExplorer unit.  *NOTE*: the cable only plugs in one way, so be careful here.

4.  If using real-time DGPS, then attach the radio antenna onto the antenna connector.  *NOTE*: it should screw on easily;  if it  doesn't, then immediatedly back it off and retry.  Be very careful not to cross-thread the connector.

5.  If using real-time DGPS, check to make sure the I/O cable is attached to the radio cable inside the green backpack.  This connection requires a NULL Modem adapter between the connectors for the GeoExplorer unit only.

6.  Turn on the GeoExplorer unit by pressing the button at the bottom of the unit.

7.  If using real-time DGPS, then turn on the RTCM receiver radio by flipping the red button on the green backpack.  *NOTE*: this button can accidentally toggle off, so recheck it if you lose RTCM reception.

8.  Set Elevation Mask in the GeoExplorer menu system: 


"Configuration --> Rover Options --> Elev Mask --> 15"

9.  Set Signal-to-Noise Ratio Threshold: 


"Configuration --> Rover Options --> SNR Mask --> 6"

10.  Set 3-D Volumetric Error Measure (PDOP) Threshold:


"Configuration --> Rover Options --> PDOP Mask --> 6"

11. Set Antenna Height (to appropriate height):


"Configuration --> Rover Options --> Antenna Ht --> 1.50"

12. Set Measurement Synchronization:


"Configuration --> Rover Options --> Not in Featura Rate --> 1s"

13. Set GPS Dynamics Mode:


"Configuration --> Rover Options --> Dynamics --> Land"

14. Set Position-fixing Mode:


"Configuration --> Rover Options --> Pos Mode --> 3D"

15. Set Real-time DGPS Radio Link Parameters:


"Configuration --> RTCM --> Mode --> Differential (i.e., GPD)"


"Configuration --> RTCM --> Port --> Port A --> Protocol --> RTCM"


"Configuration --> RTCM --> Port --> Port A --> Baud --> 9600"


"Configuration --> RTCM --> Port --> Port A --> Parity --> None"


"Configuration --> RTCM --> Port --> Port A --> Data Bits --> 8"


"Configuration --> RTCM --> Port --> Port A --> Stop Bits --> 1"


"Configuration --> RTCM --> Stale Time --> 10"

 *NOTE*: if NOT doing real-time DGPS surveying or navigation, then set:


"Configuration --> RTCM --> Mode --> Autonomous (i.e., GPS)"

SIGNAL RECEPTION CHECKS

-----------------------

1.  Check GPS Satellites: 


"GPS Status --> Sat Tracking"

    a.  Numbers are Satellite numbers

    b.  Arrows are Satellites being used for Position Fixing

    c.  Boxes are Number of Satellites being Tracked

    d.  "PDOP" should be less than parameter set above

NOTE: You may have to set RTCM mode to "Autonomous" (i.e, GPS) before trouble-shooting GPS satellite reception.  Also, sometimes power-cycling the GeoExplorer will break it out of a bogus satellite locking loop.

2.  Check RTCM Reception:


"Configuration --> RTCM"

    a.  "Msg Count" field should increment every 5 seconds;  if its 0, or freezes then resets to 0, then RTCM reception is being lost.  The "Msg Gaps" field indicates number. breaks in reception. 
    b.  Check radio power switch, cabling, connectors, antenna, and GeoExplorer configuration if no reception.
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